HILFE - Typo3 Fehler nach Umzug auf neues Hostsystem

Ab sofort füllen wir den Artikel-Bereich von Native-Network.net regelmäßig mit neuen Inhalten zu verschiedenen Themen! Direkt zu den Artikeln gelangst du

HIER

  • Hallo liebe NNs,


    ich habe einen Kunden meiner Firma umgezogen auf unser neues Hostsystem dort tritt mir jedoch im Typo3 immer folgender Fehler auf:


    Code
    1. [17-Dec-2018 14:32:58 UTC] PHP Fatal error:  require(): Failed opening required '/webhome/KUNDENNAME/public_html/typo3/sysext/install/Resources/Private/Php/../../../../../../vendor/autoload.php' (include_path='.:/opt/cpanel/ea-php70/root/usr/share/pear') in /webhome/KUNDENNAME/public_html/typo3/sysext/install/Resources/Private/Php/install.php on line 102


    Ich bekomme durchgehend diese Fehlermeldung. Auf das INSTALL_TOOL habe ich auch keinen Zugriff mehr, Berechtigungen habe ich schon gecheckt, sind alle i.O


    HS läuft auf CentOS 7 mit der neusten Version cPanel

    Website habe ich per EA auf PHP7 gestellt und alle wichtigen PHP-Addons aktiviert. Jetzt bin ich mit meinen Latein am Ende...

  • nur mal so von der idee


    was ist der unterscheid von dem alten und neuen hostsystem?

    Grundsätzlich keine,


    läuft halt nur unfter nem CentOS 7 jetzt alles weil wegen cPanel ->

    PHP 7 drinne (weil Typo es verlangt)

    Berechtigungen richtig gesetzt

    Datenbankimport erfolgreich



    Hat der Pfad die Berechtigung Chmod 777?

    Nein, weil wegen wieso? Benutzer hat vollzugrill auf die Struktur weil cPanel und 777 open würde ich ungerne bei einem Typo setzen wegen der Sicherheit Typo wird eh bald abgelöst aber es muss erstmal laufen...



  • war auf dem alten system php5? bzw was genau wurde umgezogen also die anwendung?


    wenn man das in ca erfahren darf

    2945262602.gif

    Leidenschaftlicher Analphabet mit leichtem Drang zum Sabbern.

    2945262602.gif
    Welcome to Arma, a game where Physics don't give a f*ck.

    2945262602.gif
    If (ArmA == Bullshit) exitWith {[] call f*uckThisShit};

    2945262602.gif

  • Hey sind diese Packete auch auf dem neuen Host installiert sonst geht da nix :

    • PDO
    • json
    • pcre >= 8.38
    • session
    • xml
    • filter
    • hash
    • mbstring
    • SPL
    • standardfileinfo
    • gd
    • zip
    • zlib
    • openssl
    • intl
    • mysqli (wenn du MySQL, MariaDB als Datenbankservice benutzt)
    • postgresql (wenn du PostgreSQL als Datenbankservice benutzt)
    • sqlsrv (wenn du SQL Server als Datenbankservice benutzt)
    • sqlite (wenn du SQLite als Datenbankservice benutzt)


    Und du musst auch schauen ob dein Userverzeichniss die richtigen berechtigungen hat, also ob /webhome/"KUNDENNAME" die richtigen berechtigungen hat sonst geht da garnix das ist mir auch bisher einmal erst passiert das der Server die falsche berechtigung auf das verzeichniss hatte